Camper Community Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I recently purchased a 2002 starcraft popup trailer. Everytime i plug in the shore power i blow the 20amp inline fuse. When the fuse blows it completely melts down. Obviously when the fuse is blown none of the 12v works without the shoreline. Any suggestions?
I don't want to just keep replacing the fuse because it melts the fuse and part of the fuse holder and i don't want a fire.

Battery is obviously hooked up correctly. there is a connected black and white wire which go from the converter to the battery. These wires have 30amp inline fuse. Then there is a single black wire which goes from the converter to the battery with a 20 amp fuse inline and this is the fuse that burns out.
I can't see any wornout or broken wires.


Thanks for any help and advise. I am a new RV owner

Nate
 

·
Registered
Joined
·
162 Posts
Blown fuze

Electrical problems can be tough to figure out but the first thing I wonder is is there only one circuit? If there are more I would unhook all the circuits in the fuze/breaker box, if more than one, then hook one up then another till the fuze blows. That should get you started. If there's only one circuit disconnect from the box and if there are say two outlets disconnect the two from each other and check the first or closest then go down the line. If you have a dedicated circuit such as a refer, disconnect it and turn on the circuit then pull the fuze and hook it back up and try again. Yes it's tedious but it shouldn't be too bad. Once you find what direction to look a pop up shouldn't have that much to check. Good luck and let us know how it comes out.
 
1 - 2 of 2 Posts
Top