Camper Community Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I bought my 5th wheel last year & we always have trouble at night with low amperage. This has happened at every park we go to. Some parks have been worse & it's always worse at night. We were at a really crowded park this last week & it was really bad at night. Does this sound like a inverter problem, battery problem or over crowded park? It seems like everywhere we've been this year has been really crowded. The camper is a 2006 Fleetwood, bought used. Royce
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #2 ·
Battery

I changed my battery & it seems like it helped. Haven't had a chance to check it under camping conditions. Had the fridge, air conditioner & all the lights on & low amperage detector didn't come on. Wife wants me to take it to camping world but they charge about a $100 an hr. Hope that the battery takes care of the problem. Royce:icon_smile_bbq:
 

·
Registered
Joined
·
162 Posts
low amperage

I'm curious does voltage show low also or just amps? Recently when at a RV park in California we had trouble getting our AC to work very good and found that the ambient voltage at the park was down to 107 indicating low on our meter. When we stopped on the way home at a different park where the voltage showed 115 the AC worked as it should. Also you might want to join RVNET forum because they have a really good tech section that has answered a lot of our questions. There are other forums as well so look around. Gerry
 
1 - 3 of 3 Posts
Top