Camper Community Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Roll-Tide:Just discovered this forum. I have no issues, however, my SIL has electric outlets not working. GFI types, in kitchen area (3).No reset buttons, on the outlets. Cannot locate a central GFI breaker for that part of the system. All other outlets hot. Bathroom GFI works as designed.My TT has a central GFI breaker in the box. He may have overloaded at least one outlet on his last CT.

PD: wife Brenda, 2009 AS 30 CL LMt. Dodge 6.7 TDC MC,Salem al.( near Auburn) sorry: pparki5
 

·
Registered
Joined
·
205 Posts
:welcome:to the forum.

Have you checked all the main breakers? If they are OK then I would get a multimeter and check all the outlets including any that are on the outside.

In some cases the GFI are daisy chained together so there should be one that needs to be reset. If you can't locate it I would remove the outlet covers and start checking the wires to confirm that the outlets are getting electricity. Note you could have a case where the GFI is defective and needs to be replaced or you could have a loose wire that is affecting all the outlets downstream.

Hope this helps.

Ruide
 

·
Registered
Joined
·
271 Posts
GFI could be on a hidden plug, like behind the microwave or something. you wouldn't think they'd put it there but they do some strange things, esp on friday afternoon when ready to go home or monday morning after a wild week end.
 
1 - 3 of 3 Posts
Top