Camper Community Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hello all!!!!!!! I am having furnace troubles looking for some advice. We were using the furnace last winter and it quit heating but kept blowing and will not stop blowing until you manually turn it off. Anybody had this problem before?

Thanks
 

·
Registered
Joined
·
23 Posts
I needed to replace the curcuit board on mine to get it to heat again. About $150 as I recall. This was a couple of years ago. Now I use an electric heater when we have hookups. It is much quieter
 

·
Registered
Joined
·
10 Posts
The fan is running on prepurge before it lights.The ignitor is not firing the gas so the fan keeps running.You need to have it serviced and it probably is the circiut board.
 

·
Registered
Joined
·
1 Posts
i'm having problems with my furnace not heating as well as before. Use to blow so hot you couldn't step on the vents. Now the air is barely hot. Any ideas?

I had a technician tell me it furnace is working properly after looking in the exhaust and feeling the air that came out of the vent.
 

·
Registered
Joined
·
162 Posts
furnace not heating

We had the same problem ie furnace would run but not heat and as has been said it was the circuit board for the furnace. I can't recall exactly how much to fix because we had several things fixed that were more expensive but the total came to $750 so the board must have been $150-200. As the old saw goes ya gotta pay to play. It would seem these circuit boards are common to give trouble and are designed to only be fixed by replacing the whole unit.
 
1 - 6 of 6 Posts
Top