Sink water pump not working. - CamperCommunity Forums

Join Now!

Go Back   CamperCommunity Forums > Camping > Camping Discussion

Sink water pump not working.

CamperCommunity.com is the premier Camper Community Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-25-2010, 03:54 PM
Camper
Camper Type: Popup
 
Join Date: Jul 2010
Location: Muskego, WI
Posts: 4
Default Sink water pump not working.

Hello,

We have a 2005 Forest River Flagstaff pop-up camper. We are having trouble with our sink. We filled the water tank with water and turned the pump on but no water comes out of the faucet. The motor does run when we turn it on but it keeps running, doesn't stop, and no water comes out of the faucet. (Usually the motor stops after 30 seconds when it is primed.) We checked all the fuses and the water tank. The sink does work when we hook up the home garden hose to the camper.

Does anyone know why water isn't coming out of the faucet even though the motor is running? Thank you.

Jeff
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-25-2010, 05:22 PM
Addicted Camper
Camper Type: 5th Wheel
 
Join Date: Jul 2009
Location: Mississippi
Posts: 271
Default

sounds like the pumps shot (???). could be that the supply line to the pump is blocked somehow, i'd check that first.
__________________
Bob, Beth, Sue & Sam
2006 Copper Canyon 29.5 RLS
2008 Dodge 2500 Megacab CTD
Reply With Quote
  #3  
Old 07-25-2010, 06:21 PM
Camper
Camper Type: Popup
 
Join Date: Jul 2010
Location: Muskego, WI
Posts: 4
Default

Thanks. I'll give that a try.

Jeff
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 07-26-2010, 11:34 AM
dogbone's Avatar
Addicted Camper
Camper Type: 5th Wheel
 
Join Date: Sep 2009
Location: north jersey
Posts: 265
Default

Check for a clogged screen.
You say the sink works fine on city water. When you turn the pump on does the water come out somewhere else, like the city water intake? Sometimes the check valve will stay open and the water will come out of the city water connection.
If your handy take the pump apart and carefully clean around the edges of the diaphragms. Dirt gets in there and they won't seal.
Pump is shot.
__________________
Bob & Deb
Diesel the black lab
2003 30' Cedar Creek rlbs 5 th wheel
2003 F 350 crew cab srw
6.0 powerstroke
Reply With Quote
  #5  
Old 07-26-2010, 04:18 PM
Camper
Camper Type: Popup
 
Join Date: Jul 2010
Location: Muskego, WI
Posts: 4
Default

I removed the outflow hose from the motor and water began to bubble out of the motor. I then quickly reattached it and it works now. I think it just needed to be primed. We go camping only about once a year and I think the pump dried out. My only concern now is that the pump still pumps when the water is turned off but the switch is on. (It's supposed to stop running once it is pressurized.) It's a slow (blurp, blurp) but it doesn't seem to get fully pressurized. I'll check it again in the Spring.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:13 AM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.